Building version 2.1

  • 2 Replies
  • 280 Views
Building version 2.1
« on: June 07, 2021, 04:14:49 PM »
Hi,

I've followed the steps in building version 2.1 on Windows based on the docs. Unfortunately, I'm getting some error from executing ming32-make package at the build directory.

Code: [Select]
CMake Error at <path>/build/source/cmake_install.cmake:86 (file):
  file INSTALL cannot find
  " <path>/bin/api": No such file or directory.
Call Stack (most recent call first):
  <path>/build/cmake_install.cmake:48 (include)

where
Code: [Select]
<path> is the path to the scopefun directory.

Any suggestions on how to fix this?

Thank you.

*

Dejan

  • *****
  • 117
    • View Profile
Re: Building version 2.1
« Reply #1 on: June 09, 2021, 08:25:11 AM »
Hello,

you need to set an additional variable in the cmake configuration when building the develop branch:
SCOPEFUN_BUILD_TYPE="Release" or "Debug"

Could you try that?
« Last Edit: June 09, 2021, 08:27:15 AM by Dejan »

*

Dejan

  • *****
  • 117
    • View Profile
Re: Building version 2.1
« Reply #2 on: June 18, 2021, 11:42:46 AM »
Build instructions have been updated for develop branch, which should help if you are building the new version.

https://gitlab.com/scopefun/scopefun-software/-/blob/develop/doc/build/build.pdf

Wiki page also added:
https://gitlab.com/scopefun/scopefun-software/-/wikis/Developers-Guide/Building-software-from-source

« Last Edit: June 18, 2021, 09:36:58 PM by Dejan »